Geekshop fresh install and 404 errors

Posted In Product Support
  • andrey-fd 2 years ago
    Hi!
    
    I just installed recently purchased Geekshop script, everyting looks fine but only at first page.
    
    Any links (to products, admin dashboard isnt working) - 404 error is shown.
    
    What  I should do? Looks like some handler or something like is missing...
    
    http://104.236.104.11/

    Hi!

    I just installed recently purchased Geekshop script, everyting looks fine but only at first page.

    Any links (to products, admin dashboard isnt working) - 404 error is shown.

    What I should do? Looks like some handler or something like is missing...

    http://104.236.104.11/

  • devdojo 2 years ago
    Hey Andrey-fd,
    
    Did you make sure that you uploaded the `.htaccess` file. By default it is hidden. If you do not see it on your webserver, make sure to add it, there should be one located at the root of the project called `.htaccess` which looks like this:
    
    ```
    <IfModule mod_rewrite.c>
    
      # Turn Off mod_dir Redirect For Existing Directories
      DirectorySlash Off
      
      # Rewrite For Public Folder
      RewriteEngine on
      RewriteRule ^(.*)$ public/$1 [L]
    
    </IfModule>
    ```
    
    And there should be another one located inside of the public folder at `public\.htaccess`, with the following contents:
    
    ```
    <IfModule mod_rewrite.c>
        <IfModule mod_negotiation.c>
            Options -MultiViews
        </IfModule>
    
        RewriteEngine On
    
        # Redirect Trailing Slashes If Not A Folder...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)/$ /$1 [L,R=301]
    
        # Handle Front Controller...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^ index.php [L]
    
        # Handle Authorization Header
        RewriteCond %{HTTP:Authorization} .
        RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    </IfModule>
    ```
    
    If you do not see those, go ahead and create them on your server and try it again :)
    
    Let me know if that helps.
    
    Thanks. Talk to you soon.

    Hey Andrey-fd,

    Did you make sure that you uploaded the .htaccess file. By default it is hidden. If you do not see it on your webserver, make sure to add it, there should be one located at the root of the project called .htaccess which looks like this:

    <IfModule mod_rewrite.c>
    
      # Turn Off mod_dir Redirect For Existing Directories
      DirectorySlash Off
      
      # Rewrite For Public Folder
      RewriteEngine on
      RewriteRule ^(.*)$ public/$1 [L]
    
    </IfModule>
    

    And there should be another one located inside of the public folder at public\.htaccess, with the following contents:

    <IfModule mod_rewrite.c>
        <IfModule mod_negotiation.c>
            Options -MultiViews
        </IfModule>
    
        RewriteEngine On
    
        # Redirect Trailing Slashes If Not A Folder...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule ^(.*)/$ /$1 [L,R=301]
    
        # Handle Front Controller...
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteRule ^ index.php [L]
    
        # Handle Authorization Header
        RewriteCond %{HTTP:Authorization} .
        RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    </IfModule>
    

    If you do not see those, go ahead and create them on your server and try it again :)

    Let me know if that helps.

    Thanks. Talk to you soon.

  • andrey-fd 2 years ago
    Hi! I checked my directories, these files are present with same content you provided.
    
    May be something wrong with access rights for these files?

    Hi! I checked my directories, these files are present with same content you provided.

    May be something wrong with access rights for these files?

  • andrey-fd 2 years ago
    i'm found that module ModRewrite has been isnt enabled. Now everything fine!

    i'm found that module ModRewrite has been isnt enabled. Now everything fine!

  • devdojo 2 years ago
    Awesome, glad to hear :)

    Awesome, glad to hear :)

  • axel-james 8 months ago
    These errors are common to have while doing work because we all did mistakes. The [https://www.australian-writings.org/](https://www.australian-writings.org/) wrote a research papers on how we can tackles these errors and then solve it.

    These errors are common to have while doing work because we all did mistakes. The https://www.australian-writings.org/ wrote a research papers on how we can tackles these errors and then solve it.

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
Want to create your own SAAS?

I can teach you to create your own Software as a Service. Click here to learn more!

Visit SAAS Adventure!