Upload new logo issue Pixel v2

Posted In Product Support
  • genxer-frado 2 years ago
    I'm uploading new logo on admin page i see successfully uploaded But it still showing old logo on frontend side. It is not changing how to change it?

    I'm uploading new logo on admin page i see successfully uploaded But it still showing old logo on frontend side. It is not changing how to change it?

  • devdojo 2 years ago
    Can you go ahead and update `resources/views/themes/default/layouts/app.blade.php` line `86` - `94` from:
    
    ```
    @if(setting("color_scheme", "light") == "dark" || (isset($_COOKIE['theme']) && $_COOKIE['theme'] == 'default_dark'))
        <a href="/" class="logo"><img src="/assets/default/img/light-logo.png" /></a>
    @else
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/logo.png" /></a>
        <?php }?>
    @endif
    ```
    
    to:
    
    ```
    @if(setting("color_scheme", "light") == "dark" || (isset($_COOKIE['theme']) && $_COOKIE['theme'] == 'default_dark'))
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/light-logo.png" /></a>
        <?php }?>
    @else
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/logo.png" /></a>
        <?php }?>
    @endif
    ```
    
    And that should solve your issue.
    
    Additionally, you can download the latest version from here: [https://devdojo.com/products](https://devdojo.com/products) and those should be updted :)
    
    Thanks.

    Can you go ahead and update resources/views/themes/default/layouts/app.blade.php line 86 - 94 from:

    @if(setting("color_scheme", "light") == "dark" || (isset($_COOKIE['theme']) && $_COOKIE['theme'] == 'default_dark'))
        <a href="/" class="logo"><img src="/assets/default/img/light-logo.png" /></a>
    @else
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/logo.png" /></a>
        <?php }?>
    @endif
    

    to:

    @if(setting("color_scheme", "light") == "dark" || (isset($_COOKIE['theme']) && $_COOKIE['theme'] == 'default_dark'))
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/light-logo.png" /></a>
        <?php }?>
    @else
        <?php if (setting('logo', '')){ ?>
            <a href="/" class="logo"><img src="{{ Voyager::image(setting('logo')) }}" /></a>
        <?php }else {?>
            <a href="/" class="logo"><img src="/assets/default/img/logo.png" /></a>
        <?php }?>
    @endif
    

    And that should solve your issue.

    Additionally, you can download the latest version from here: https://devdojo.com/products and those should be updted :)

    Thanks.

  • genxer-frado 2 years ago
    Perfect,
    Thanks

    Perfect, Thanks

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
tnylea
Cheers Friend!

I'm Tony, the creator of this site. I'm trying to increase my twitter following. Want to follow me?

Follow @tnylea If not, no worries :)