relative_url_to_image_assets and avatar_image_database_field not working

Posted In Laravel
  • firas-jerbi 1 year ago
    Hello
    I wanted to display the user photo in the chatter forums  in front of every post but did not worked,
    the photos are located in public/img and the field name in the database is 'pic'
      'relative_url_to_image_assets'  => '/public/img',
      'avatar_image_database_field'   => 'pic',
    			the View file : 
    				
    		
    	<span class="chatter_avatar_circle" style="background-color:#<?= \DevDojo\Chatter\Helpers\ChatterHelper::stringToColorCode($discussion->user->{Config::get('chatter.user.avatar_image_database_field')}) ?>">
    	{{ strtoupper(substr($discussion->user->{Config::get('chatter.user.avatar_image_database_field')}, 0, 1)) }}
    	</span>
    													
    													
    				

    Hello I wanted to display the user photo in the chatter forums in front of every post but did not worked, the photos are located in public/img and the field name in the database is 'pic' 'relative_url_to_image_assets' => '/public/img', 'avatar_image_database_field' => 'pic', the View file :

    <span class="chatter_avatar_circle" style="background-color:#<?= \DevDojo\Chatter\Helpers\ChatterHelper::stringToColorCode($discussion->user->{Config::get('chatter.user.avatar_image_database_field')}) ?>">
    {{ strtoupper(substr($discussion->user->{Config::get('chatter.user.avatar_image_database_field')}, 0, 1)) }}
    </span>
    												
    												
    			
    

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
Want to create your own SAAS?

I can teach you to create your own Software as a Service. Click here to learn more!

Visit SAAS Adventure!