403 error GeekShop script

Posted In General
  • istvan-biro 2 years ago
    Hello,
    I bought your geekshop scitpt, and I try install godaddy host, but I always got 403 error. I try manual install, I migrate db, etc, but also get 403 error.
    Pls help me!
    
    Thanks

    Hello, I bought your geekshop scitpt, and I try install godaddy host, but I always got 403 error. I try manual install, I migrate db, etc, but also get 403 error. Pls help me!

    Thanks

  • devdojo 2 years ago
    Hi Istvan-biro,
    
    I'm sure I can help you get this script installed successfully. I just need to get a bit more info from you :)
    
    * Can you let me know what OS you are currently on. 
    * Are you trying to install this locally?
    * What version of PHP are you currently running?
    * Do you have any familiarity with Laravel? If not, no worries :)
    
    Let me know the questions above and I can help you further with this.
    
    Thanks.

    Hi Istvan-biro,

    I'm sure I can help you get this script installed successfully. I just need to get a bit more info from you :)

    • Can you let me know what OS you are currently on.
    • Are you trying to install this locally?
    • What version of PHP are you currently running?
    • Do you have any familiarity with Laravel? If not, no worries :)

    Let me know the questions above and I can help you further with this.

    Thanks.

  • istvan-biro 2 years ago
    I think the problem is, no htaccess file.
    Godaddy host , linux OS, i dont know what kind linux disr.
    Php version 5.6
    No, I havent got familiarity with Laravel.
    

    I think the problem is, no htaccess file. Godaddy host , linux OS, i dont know what kind linux disr. Php version 5.6 No, I havent got familiarity with Laravel.

  • devdojo 2 years ago
    So, the `.htaccess` file should be located in the public folder `/public/.htaccess`.
    
    the location that your website should be looking at is the `/public` folder. So instead of your host pointing at the root of the folder which contains the folowing folders:
    
    - app (folder)
    - bootstrap (folder)
    - config (folder)
    - database (folder)
    - **public (folder)** *This is the folder your website should be pointing to*
    - resources (folder)
    - routes (folder)
    - storage (folder)
    - tests (folder)
    - vendor (folder)
    - ... remaining files
    
    It should be pointing to the above `/public` folder.
    
    Let me know if that makes sense and let me know if that gets you any closer to getting it installed :)
    
    Are you on Godaddy Shared hosting? I did find this article that explained the steps to get a Laravel app up and running on a [Godaddy shared hosting server](https://medium.com/@kunalnagar/deploying-laravel-5-on-godaddy-shared-hosting-888ec96f64cd#.tna9714fm).
    
    Keep me posted. Thanks!

    So, the .htaccess file should be located in the public folder /public/.htaccess.

    the location that your website should be looking at is the /public folder. So instead of your host pointing at the root of the folder which contains the folowing folders:

    • app (folder)
    • bootstrap (folder)
    • config (folder)
    • database (folder)
    • public (folder) This is the folder your website should be pointing to
    • resources (folder)
    • routes (folder)
    • storage (folder)
    • tests (folder)
    • vendor (folder)
    • ... remaining files

    It should be pointing to the above /public folder.

    Let me know if that makes sense and let me know if that gets you any closer to getting it installed :)

    Are you on Godaddy Shared hosting? I did find this article that explained the steps to get a Laravel app up and running on a Godaddy shared hosting server.

    Keep me posted. Thanks!

  • istvan-biro 2 years ago
    It's okay. I have every folder. Pls check my website, something wrong with it. http://boltkereso.com. 

    It's okay. I have every folder. Pls check my website, something wrong with it. http://boltkereso.com.

  • kevin-rigby 2 years ago
    hi there i purchased this script to and carnt seem to get it to install on goodaddy hosting always get a Forbidden page.
    

    hi there i purchased this script to and carnt seem to get it to install on goodaddy hosting always get a Forbidden page.

  • devdojo 2 years ago
    Ok, I see that it seems to be loading on your site but it looks like the images do not seem to be displaying. You probably need to add a symlink to your storage folder.
    
    If you navigate to your public folder and run the following command:
    
    ```
    ln -s ../storage/app/public storage
    ```
    
    Let me know if that helps. Thanks :)

    Ok, I see that it seems to be loading on your site but it looks like the images do not seem to be displaying. You probably need to add a symlink to your storage folder.

    If you navigate to your public folder and run the following command:

    ln -s ../storage/app/public storage
    

    Let me know if that helps. Thanks :)

  • devdojo 2 years ago
    Kevin-rigby,
    
    Have you went through the previous steps that I discussed. You may not be pointing your site to the correct folder. It should be pointed to the `/public` folder :)
    Let me know if that helps. If not, we can keep on investigating :)
    
    Thanks.

    Kevin-rigby,

    Have you went through the previous steps that I discussed. You may not be pointing your site to the correct folder. It should be pointed to the /public folder :) Let me know if that helps. If not, we can keep on investigating :)

    Thanks.

  • kevin-rigby 2 years ago
    hi mate thanks for reply, not sure how that is done, im new to all this script installion. 

    hi mate thanks for reply, not sure how that is done, im new to all this script installion.

  • devdojo 2 years ago
    Hey Kevin-rigby,
    
    Do you know what kind of stack you have on your server? I'm assuming you are running Apache correct?
    You may also want to try contacting Godaddy and asking them if they can point the domain to the /public folder of the application. I found an article [here](https://www.godaddy.com/help/specifying-a-new-default-document-root-on-your-hosting-account-4175) that explains what we are trying to do.
    
    Another option may be to point the domain to the `/public` folder by using a .htaccess file. In the root of you application create a new file and call it `.htaccess`. Next, add the following to that file:
    
    ```
    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteRule ^(.*)$ public/$1 [L]
    </IfModule>
    ```
    
    Then see if you are able to load your site. Let me know if one of these 2 solutions has helped solve your issue :)
    
    Thanks! Talk to you soon.

    Hey Kevin-rigby,

    Do you know what kind of stack you have on your server? I'm assuming you are running Apache correct? You may also want to try contacting Godaddy and asking them if they can point the domain to the /public folder of the application. I found an article here that explains what we are trying to do.

    Another option may be to point the domain to the /public folder by using a .htaccess file. In the root of you application create a new file and call it .htaccess. Next, add the following to that file:

    <IfModule mod_rewrite.c>
      RewriteEngine On
      RewriteRule ^(.*)$ public/$1 [L]
    </IfModule>
    

    Then see if you are able to load your site. Let me know if one of these 2 solutions has helped solve your issue :)

    Thanks! Talk to you soon.

Please login or signup to leave a response.

Login

or Sign Up

Sign Up

or Login
×
Want to create your own SAAS?

I can teach you to create your own Software as a Service. Click here to learn more!

Visit SAAS Adventure!